トップページ » IT » パソコン周辺機器 » アイ・オー・データ機器のWN-G54/CB3を導入(2)

アイ・オー・データ機器のWN-G54/CB3を導入(2)

アイ・オー・データ機器のWN-G54/CB3を導入(2):パソコン周辺機器

前回の記事アイ・オー・データ機器のWN-G54/CB3を導入でアイ・オー・データ機器のWN-G54/CB3を導入したことについて記載しましたが、その後、問題が発生してしまい、結局、元のWN-B11/USBSLに戻しました。
問題点と経緯について、簡単に記載します。

問題点は、通信していない時のCPU使用率です。

環境ですが、本体はHPのnx9030/CTで、OSはWindows XP Professional SP2です。
アプリケーションをすべて終了させた状態で測定しました。
アプリケーションはいろいろとインストールしてありますが、原因究明のため、ちょっと手間が掛かりましたが、OSを再インストールしてデフォルトの状態にして測定しても、ほぼ同じ結果であることが確認されました。
なお、ドライバは最新版にして確認しています。


WN-B11_USBSL_CPU使用率まず、左の図に、IEEE802.11b対応 無線LANアダプタ USB接続スティックタイプWN-B11/USBSLを使った時の、CPU使用率のグラフを示します。
(クリックすると拡大画像が表示されます。)
放置して30分くらい経った状態です。
CPU使用率は、常時0%〜2%程度の範囲内で、限りなくゼロに近いです。
おそらく、これが普通の状態だと思います。


WN-G54_CB3_CPU使用率続いて、IEEE802.11g/b対応 無線LANアダプター(Card Bus PCカードタイプ)WN-G54/CB3を使った時の、CPU使用率のグラフを示します。
(クリックすると拡大画像が表示されます。)
こちらも、放置して30分くらい経った状態です。
CPU使用率は、0%〜45%の範囲内で上下しており、平均すると20%くらいでした。
この環境下で、WordやExcelなどのアプリケーションを使った場合、WN-B11/USBSLの時と比べて明らかにストレスがあります。

こうなると、まず、何がCPUを消費しているのか、調べることになります。
ところが、WN-G54/CB3の使用時、タスクマネージャ内の「プロセス」タブでの「System Idle Process」は、いつも97〜99を示していました。
System Idle Processが99%と表示される場合、CPUは1%しか使用されていないものだと思っていたのですが、そうではないのです。
実際に、「プロセス」タブを凝視していたのですが、System Idle Processが97%で、CPU使用率が40%という状態が存在することが確認できました。

アイ・オー・データ機器のサポートセンターにも問い合わせて、一度、WN-G54/CB3を新品に交換してもらいましたが、それでもCPU使用率が高くなる現象は再現しました。
サポートセンターのほうでは、これまでこのような現象の報告はされていないとのことでした。

推測ですが、HPのnx9030/CTが使用しているPCMICAアダプタ(Texax Instruments PCI-1410 CardBus Controller)と、WN-G54/CB3との相性が良くないのではないかと考えています。

Webサーチしたのですが、同様の現象は見当たらなかったので、私自身でこちらにアップしてみました。
ご参考になれば、幸いです。

【追記】どうやら、上記の現象は電波状態に依存するようです。
無線LANのアクセスポイントとの間に障害物がない状態にしたところ、CPU使用率は1〜2%程度で安定しました。

by 管理人  at 16:49
この記事のカテゴリ
以下のリンクから関連する記事をお読みいただけます。

コメント(承認制です)

コメントはありません

コメントを書く



(公開されません)


保存しますか?


(書式を変更するような一部のHTMLタグを使うことができます)

(誹謗中傷にあたるコメント、及び的外れなコメントは、受信されません。)

「アイ・オー・データ機器のWN-G54/CB3を導入(2):パソコン周辺機器」について解説しています。